MODO

Nuovo | apre un nuovo file di tipo .mdb destinato a contenere l'intera base di dati
Apri | apre un file di tipo .mdb contenente una specifica base di dati
Chiudi | chiude il file .mdb
Stampa | crea un file word contenente il modello del questionario predisposto
Compatta | avvia il programma standard di compattazione dei file
Ripristina | avvia il programma standard di ripristino dei file danneggiati
Esci | esce da MoDo


Nuovo | inserisce un nuovo record (quesito) in fondo al questionario aperto; per la specificazione delle caratteristiche del quesito si osservino le indicazioni relative alla struttura del questionario
Inserisci | inserisce un nuovo record (quesito) prima del record corrente; per la specificazione delle caratteristiche del quesito si osservino le indicazioni relative alla struttura del questionario
Sposta prima | inverte la posizione del record corrente con la posizione del record precedente
Sposta dopo | inverte la posizione del record corrente con la posizione del record successivo
Cancella | elimina il record (quesito) corrente
Edita | permette di correggere il record (quesito) corrente; equivale al doppio click del mouse


Commenti | visualizza il questionario con le linee di commento
Commenti | visualizza il questionario senza le linee di commento
Quesiti associati | visualizza i quesiti associati (vedi struttura del questionario)
Quesiti associati | non visualizza i quesiti associati


Crea database crea gli archivi dei dati gestiti da MORIS


Manuale | apre il manuale di utilizzo
Info | fornisce informazioni sul copyright


in costruzione


MORIS

Apri | apre il file di tipo .mdb creato da MoDo e destinato a raccogliere le risposte fornite al questionario
Chiudi | chiude il documento aperto
Stampa | crea un file word contenente le risposte al questionario
Compatta | avvia il programma standard di compattazione dei file
Ripristina | avvia il programma standard di ripristino dei file danneggiati
Esci | chiude MoRis


MORIS

Nuovo | permette di inserire un nuovo record/questionario
Imposta default | imposta un valore di default per il campo
Cancella | distrugge le informazioni del record corrente
Vai al primo record | permette di posizionarsi sul primo questionario in ordine d’immissione
Vai all’ultimo record | permette di posizionarsi sull’ultimo questionario in ordine d’immissione
Finestra secondaria | segnalatore di finestra secondaria non attiva
Chiudi finestra | chiude la finestra secondaria attivata (vedi Struttura)
Annulla evidenza | elimina il contrassegno per il record corrente (vedi Evidenzia)
Evidenzia | inserisce un contrassegno per il record corrente (il rettangolo giallo in basso a sinistra del form) per permettere di ritrovarlo celermente (vedi Vai a marcato) in un secondo tempo; il comando è utile per segnalare questionari incompleti
Vai al successivo evidenziato | permette di posizionarsi su un questionario evidenziato (vedi Evidenzia) successivo al record corrente


MORIS

Mostra solo... | permette di impostare un filtro per visualizzare solo i questionari che rispondono al criterio di selezione
Mostra tutti | annulla un eventuale filtro impostato con Mostra solo... e visualizza tutti i questionari


MORIS

Manuale | apre il manuale di utilizzo
Info | fornisce informazioni sul copyright


MORIS

in costruzione


DORIS

D O R I S (DOmande, RISposte)
è un insieme di procedure per la gestione dei questionari. DORIS si compone di due distinti programmi:
M O D O (MOdulo DOmande)
permette di impostare la struttura di un nuovo questionario, di stampare i moduli per l'acquisizione delle informazioni, di generare la maschera per il data entry dei dati;

per saperne di più fare clic qui

M O R I S (MOdulo RISposte)
permette di caricare i dati dei questionari, di visualizzarli secondo criteri di selezione e ricerca, di stamparli.

per saperne di più fare clic qui


DORIS

D O R I S è già stato utilizzato in attività di monitoraggio e valutazione.
Tuttavia è ancora incompleto e in parte instabile: col tempo cercherò di perfezionarlo. Ho bisogno però di aiuto. La versione Beta è riservata a utenti esperti in grado di fornirmi suggerimenti utili per il completamento della versione.
Per ricevere DORIS inviare una mail (oggetto: DORIS) a f.cinquegrani@iname.com (non ancora attivo; se volete potete scaricare la documentazione), specificando il vostro nominativo, l'indirizzo, l'impegno a non diffondere i materiali che vi saranno inviati e, se volete, l'attività da voi svolta o l'interesse che avete al programma. I dati non saranno diffusi in alcun modo: li utilizzerò unicamente per comunicare eventuali aggiornamenti.
Il funzionamento di MODO
Il funzionamento di MORIS


Dopo aver lanciato MODO, selezionare l'icona indicata. La barra di stato riporta il significato del comando: Nuovo questionario. Al comando si accede anche dalla voce di menu File/Nuovo...


Indicare quindi un nuovo nome e salvare. Il database che raccoglie le informazioni sulla struttura del questionario è un file di tipo Access (.MDE). Lo stesso database raccoglierà successivamente i questionari compilati.


A prima vista non sembra essere accaduto alcunché. Notiamo però che l'icona Apri questionario si è trasformata nell'icona Chiudi questionario, che nella barra del titolo appare il nome del file e che alcuni pulsanti, prima disabilitati, ora sono attivi.


Selezioniamo l'icona indicata che è segnalata nella barra di stato come Nuovo quesito e che corrisponde alla voce di menu Modifica/Nuovo record...


...ed ecco comparire la finestra dell'editor. Quando inizializziamo un nuovo record, la finestra dell'editor si apre sempre alla voce Commento. Qui è possibile inserire note relative al lavoro da svolgere: i commenti non saranno visualizzati nelle finestre di data entry. Dopo aver compilato la scheda (testo visualizzato nella finestra principale ed eventuali note aggiuntive) salvare con un clic sul pulsante Ok.


Si torna così alla finestra principale, dove troviamo una prima riga corrispondente al primo inserimento effettuato. Continuiamo con un nuovo inserimento con un clic sull'icona già indicata.


E' bene iniziare un questionario con un titolo. Per far questo spostiamoci nella finestra Titolo con un clic sulla tab.


Quindi indichiamo un titolo (Testo del quesito, campo obbligatorio) e un eventuale sottotitolo (Sottotitolo, campo opzionale). Non modificheremo né il valore di default del campo Ripetibilità, né l'opzione Non condizionato. Vedremo successivamente il significato di questi campi. Confermiamo l'inserimento con un clic sul pulsante Ok e torniamo così nella finestra principale.


Continuiamo con un nuovo inserimento. Il quesito 'Titolo dell'ultimo libro letto' è un quesito a risposta aperta (non possiamo associare una lista di possibili risposte) di tipo testuale. Selezioniamo quindi la tab Testo, indichiamo il testo del quesito, il numero di caratteri del campo destinato a raccogliere la risposta e un eventuale valore da associare alla mancata risposta (default). Completato l'inserimento, confermiamo il tutto con un clic sul pulsante Ok.


Chiediamo un breve giudizio sul libro indicato. Per contenere le risposte non basta un semplice campo di Testo. Perciò selezioniamo la finestra Memo e indichiamo un numero di righe sufficiente a visualizzare le possibili risposte. Con un clic sul pulsante Ok torniamo nella finestra principale.


Qui ci rendiamo conto di un errore. Non tutti possono e debbono rispondere all'ultimo quesito; solo quelli che hanno indicato un ultimo libro letto. Molti intervistati potrebbero non ricordarne il titolo, o non vogliono rispondere a questa specifica domanda. Torniamo quindi nella finestra dell'editor con un clic sull'icona indicata, segnalata come Modifica quesito e corrispondente alla voce Modifica/Modifica. Lo stesso risultato si ottiene con un doppio clic sulla cella ove appare il quesito.


Nella finestra dell'editor, imponiamo il vincolo con un clic su Condizionato. Quando confermeremo l'inserimento con un clic sul pulsante Ok, si aprirà un nuova finestra che ci permette di impostare la condizione.
Selezioneremo dalla finestra a discesa il Quesito cui far riferimento ('Titolo dell'ultimo libro letto'), un Operatore (in questo caso: <> diverso da...), infine il Valore della risposta ('Non ricordo...', il valore di default del precedente quesito).
Proviamo a rileggere: il quesito 'Breve giudizio sull'ultimo libro letto' ossia il quesito corrente, si applica a condizione che la risposta al quesito 'Titolo dell'ultimo libro letto' sia diversa da (<>) 'Non ricordo...'.
Confermiamo con un clic sul pulsante Ok e torniamo nella finestra principale.


Un attimo di pausa prima di riprendere il lavoro.
Mentre riguardiamo quanto finora fatto notiamo che tutti i quesiti (non i commenti, né i titoli) vengono numerati in ordine progressivo. Commenti e titoli possono essere nascosti (menu Visualizza) in modo da avere un quadro più chiaro dei quesiti del questionario. Notiamo anche che il quesito 'Breve giudizio...' è rientrato rispetto a 'Ultimo libro letto'. E' segno che il quesito, così come l'abbiamo impostato, è assoggettato a condizione. Infine, la barra di stato in basso ci segnala la tipologia del quesito e eventuali vincoli.


Riprendiamo la scrittura del questionario. Ci soffermiamo sui successivi tre quesiti solo per indicarne la tipologia: tutti quesiti a risposta aperta, di tipo Intero il primo (Numero di libri letti...), di tipo Decimale il secondo (Spesa media...), di tipo Data il terzo (Data d'acquisto...).


Il successivo quesito richiede un'unica risposta su una lista chiusa di possibili risposte. La tipologia del quesito sarà Singola. Avviamo con un clic sulla prima cella l'indicazione degli item della lista. La cella si colorerà di giallo intenso per indicare che siamo in modalità di scrittura. Digitiamo vado comunque..., e confermiamo con Invio, con un successivo Invio entriamo in modalità di scrittura nella successiva cella.
L'operazione Registra/Edita successivo realizzata con il doppio Invio è costante nelle operazioni su lista e sarà particolarmente importante in MORIS per velocizzare l'operazione di data entry.


Il successivo quesito non si differenzia dal precedente se non per il fatto che qui sono possibili più risposte. Nella tipologia Multipla potremo indicare il numero massimo di risposte possibili oltre a un'eventuale valore di default. La coerenza di questi valori con il numero di item della lista non è al momento controllata dal programma.


Con la risposta aperta su lista, completiamo la rassegna delle tipologie di quesito. La tipologia Lista, associa la tipologia Singola alla tipologia Testo: rende possibile indicare uno degli item della lista o fornire una risposta non contemplata nella lista. E' questo il caso ricorrente di una lista che si conclude con un Altro (specificare: ...)


Quanto appreso finora permette di produrre la maggior parte dei questionari. Esistono tuttavia questionari che richiedono la registrazione su più archivi in quanto l'unità di riferimento statistico non è unica. Se chiediamo più informazioni (titolo, autore, riassunto) relative ai libri letti, l'unità statistica di riferimento è ciascun libro letto in rapporto di molti a uno con l'unità statistica principale (il lettore). Vediamo come realizzare questa struttura più complessa.


Inseriamo un titolo, indicando nel campo ripetibilità il numero massimo di risposte associate alla sezione del questionario. In questo caso, come lascia intendere il testo del quesito, 3. Quindi confermiamo con il pulsante Ok.


Compiliamo normalmente il successivo quesito, ma indichiamo con un clic sul pulsante di opzione che esso è Associato. Quando confermeremo l'inserimento con un clic sul pulsante Ok...


...si aprirà una nuova finestra condizione, dove potremo indicare, selezionandolo dalla lista, il quesito a cui il quesito corrente è associato. Selezionando il titolo 'Di tre libri...' il quesito corrente ne eredita le condizioni di ripetibilità.


Non diversamente, per i successivi quesiti, forniremo gli stessi parametri di associazione. Nella finestra principale, i quesiti associati saranno evidenziati da un rientro del testo del quesito.
Siamo ora pronti per le procedure finali, ossia per i due output del programma. Il primo è la stampa del questionario. Avvieremo la procedura con un clic sul pulsante evidenziato, segnalato nella barra di stato come Crea file Word e corrispondente alla voce di menu File/Stampa.


Il questionario verrà visualizzato nella finestra anteprima di stampa di Word. Potremo accettarlo come si presenta o modificarne il layout (non ovviamente la struttura e la successione dei quesiti). Possiamo direttamente stamparlo e salvarlo.


L'ultima operazione è la creazione degli archivi per il data entry. Una volta iniziato il data entry, una nuova creazione degli archivi distruggerà quelli precedenti (è comunque possibile recuperare le informazioni già inserite via Access). Si suggerisce quindi di procedere quindi alla creazione degli archivi, verificarne la corretta progettazione con MORIS, quindi rientrare in MODO e rigenerare per l'ultima volta gli archivi.
L'operazione viene realizzata con un clic sull'icona evidenziata, segnalata dalla voce Genera archivi della barra di stato e corrispondente alla voce di menu Strumenti/Genera archivi.


Chiudiamo quindi il questionario con un clic sull'icona evidenziata, segnalata dalla voce Chiudi questionario nella barra di stato e corrispondente alla voce di menu File/Chiudi.


Possiamo ora progettare un nuovo questionario, aprirne uno già registrato per apporvi modifiche (ogni modifica comporta la rigenerazione degli archivi), o uscire definitivamente da MODO con un clic sulla prima icona, segnalata dalla voce Esci nella barra di stato e corrispondente alla voce di menu File/Esci.
ritorna a DORIS


MORIS

Dopo aver lanciato MORIS, selezionare l'icona indicata. La barra di stato riporta il significato del comando: Apri file. Al comando si accede anche dalla voce di menu File/Apri...


MORIS

Individuare quindi il file di tipo MDE predisposto da MODO per il data entry dei questionari e aprirlo.
All'apertura del file potrebbero verificarsi degli errori: il file non è di tipo DORIS o nel file, di tipo DORIS, non sono state generate le tabelle per il data entry. Non è possibile in tal caso procedere: non è possibile infatti registrare i questionari tramite MORIS su un qualsiasi file, ma solo sui file predisposti da MODO.


MORIS

Quando viene aperto un nuovo questionario, la finestra principale del programma presenterà unicamente la lista dei quesiti. Per avviare il data entry è necessario selezionare l'icona evidenziata, segnalata nella barra di stato come Aggiungi e corrispondente alla voce di menu Record/Aggiungi.


MORIS

A questo punto la griglia conterrà, oltre ai quesiti, la colonna da utilizzare per il data entry. Questa potrà essere del tutto vuota o parzialmente già compilata: in essa figurano infatti alcuni valori di default impostati in sede di progettazione del questionario.
Selezioniamo con il mouse, rendendola attiva, la prima cella destra della griglia, quella evidenziata in blu, e avviamo la compilazione. E' opportuno a questo punto mettere da parte il mouse: il data entry verrà condotto da tastiera secondo la successione Invio/Input/Invio o Invio/Input/Cntl+Invio, ossia entrando di volta in volta con Invio in modalità Inserimento e confermando con Invio, o con Cntl+Invio, quando il quesito è su più righe, l'inserimento effettuato. Dopo ogni inserimento la cella attiva avanza automaticamente nell'ordine di successione dei quesiti.
Gli indicatori numerici in basso ci dicono che siamo nel primo record (l'uno a sinistra) di un totale di un record (l'uno a destra).


MORIS

Dopo il primo Invio la selezione si sposterà dalla prima cella alla successiva: la prima cella è infatti solo un titolo e non richiede alcun input. Con un successivo Invio entreremo in modalità Inserimento nel primo quesito del questionario. In modalità Inserimento la cella è di colore giallo intenso, mentre la barra di stato ci fornisce suggerimenti sulla compilazione. Ogni precedente input e quindi anche gli eventuali valori di default saranno evidenziati. Quindi un nuovo input sovrascriverà il precedente; non è necessaria la cancellazione.


MORIS

Dopo aver digitato la corretta risposta al quesito potremo scegliere di confermarla con Invio o annullarla con Esc.


MORIS

Dopo la conferma, nella finestra principale succedono più cose: la cella conterrà l'informazione digitata e sarà tornata al colore base, la successiva cella sarà ora la cella attiva, vedremo comparire un quesito dove prima non c'era. Il quesito 'Breve giudizio...' è dipendente dalla risposta fornita al primo quesito, e sarà visibile o meno in relazione alla risposta fornita al primo quesito.
Poichè la cella attiva (la cella attiva è riconoscibile dal bordo punteggiato) è ora la successiva cella, ci basterà un Invio per entrare in modalità Inserimento nella successiva cella.


MORIS

A differenza del primo, questo quesito è su più righe. Qui l'Invio ha il significato di A capo, quindi per registrare l'inserimento dovremo digitate Cntl+Invio, come ci suggrisce la barra di stato.


MORIS

Nei successivi inserimenti, non dovremmo aver problemi: il formato numerico o di data è indipendente dalla modalità di inserimento; noi ci limiteremo a scrivere 7, 20 e 22/12/1998 e il programma adeguerà l'input al formato richiesto 07, 20.00, 22/12/98.
Nei quesiti a risposta chiusa come quello qui illustrato, vedremo apparire una finestra secondaria con la lista delle alternative: qui selezioneremo la risposta utilizzando le frecce alto-basso e confermeremo la scelta con Invio. L'Invio chiude la finestra secondaria, registra la risposta e sposta la cella attiva al successivo quesito.


MORIS

in costruzione...


MORIS

in costruzione...
ritorna a DORIS


DORIS

 D O R I S
Programmi per la gestione di questionari


 M O D O
I passi per costruire un questionario


 M O D O
I comandi


MORIS

 M O R I S
Il data entry dei questionari


MORIS

 M O R I S
I comandi